-
-
Notifications
You must be signed in to change notification settings - Fork 968
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
Port GUI rendering improvements from JGRPP #8217
Conversation
8eefbf1
to
7058896
Compare
(resolved by 4455011) Ugh! What is a |
(resolved by 4455011) *** Error in `./openttd': double free or corruption (out): 0x00005560ee826ec0 *** Clearly, there is an errant pointer in that patch that is busy stomping all over memory. Locating that ought to keep me busy for a while %-( |
I do not understand why the automated checks are failing; as far as I'm aware, the parts of the code it is complaining about were not touched by the patch? |
You'll need this commit or something like it as well: JGRennison/OpenTTD-patches@4bad77c You can't use bare malloc/free for structures with non-POD fields like std::vector |
You'll need this commit as well, as otherwise you'll run off the end of the viewport dirty block buffer, probably causing the issue you noticed, JGRennison/OpenTTD-patches@7f32bb3 |
Thanks. I knew there had to be something I missed. Frankly, I'm surprised the game managed to run as long as it did without crashing. |
I am quite liking your approach to the problem, @JGRennison. You're quite right that the majority of the widget drawing cannot benefit from a complicated grid-based dirty tracking scheme; as most of them are simple, non-overlapping rectangles anyway. And tracking each viewport independently is also rather genius, not least of all because it gives each widget the ability to manage its own invalidation. I can't wait to see how I can build on top of this solid foundation 😎 |
Short housekeeping note: Consider converting this PR to draft status as long as you wouldn't consider merging it. |
Good idea. How do I do that? |
e4c6061
to
4455011
Compare
I consider that this is ready to be merged now. Granted, it still has the patch that renames |
152de98
to
0fde2fa
Compare
b078c96
to
44020be
Compare
Rebased to resolve the merge-conflict with |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
There are also a few strings that spell VIEWPORT
as VIEW_PORT
. I have not touched those, as I do not know the consequences of doing so.
src/core/math_func.hpp
Outdated
@@ -361,6 +361,30 @@ static inline int DivAwayFromZero(int a, uint b) | |||
} | |||
} | |||
|
|||
/** | |||
* Computes a / b rounded towards negative infinity for signed a and unsigned b. |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Documentation says "signed a and unsigned b", but function just takes the same type. Could be really fancy and use https://en.cppreference.com/w/cpp/types/is_unsigned with an assert_compile
if you like ;)
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
You know, cppreference.com has become my new favorite website over the last few weeks? It's brilliant!
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I decided to go for the best of both worlds; an assert_compile
to guarantee we're dealing with arithmetic types, and a runtime assert
if unsigned b
turns out to be signed after all. If I can make the compiler spit out a warning that b
should be an unsigned type, then that's all the better 😉
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I also threw in a static_cast
to the type of a
, since that seems to be the in thing to do with these particular functions.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Instead of "signed a and unsigned b" it should probably say something like "positive values of b" or "b > 0".
T does not strictly have to be signed for the function to return correct results.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
All the other related functions use an unsigned type for the divisor; and I have rigged the function to work either way; if it's fed s signed divisor, you'll get a run-time assertion, else a compile-time assertion.
For that matter, it will work with an unsigned dividend, too.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Is there any reason why these functions actually need to be templated? I have been toying with templating all the other related functions; and there's a lot of work to get right. I actually got my abomination to compile; but there's no way to guarantee the resulting program is correct (i.e. choosing generic types of an appropriate width). For instance; if supplied with an rvalue of (byte_x * 100), will the templated type be 8 bits, 16 bits, signed, or unsigned?
Needs a rebase :) Cleanup: Improve documentation of dirty block system. -> Doc |
Thanks for the feedback. I'll try to add some spice to my commit message. And here I was thinking that the mass renaming of |
I have also become aware that some of my pull requests can have a tendency to veer off topic. I sometimes have a hard time recognising where a commit belongs; so if that happens, please let me know and I will happily split them off into a separate topic branch. |
src/window_gui.h
Outdated
* @see ViewportData::Create() | ||
* @see ViewportData::~ViewportData | ||
*/ | ||
typedef std::vector<std::weak_ptr<ViewPort>> ViewportCacheBase; |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Random thought: Do we actually need the complexity and overhead of weak pointers here, or would it be better to place viewport management under the memory pool system, where we already get iteration (and, I assume, automagic memory management) for free?
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I don't really see why either of these are necessary. struct ViewPort already has a single owner: struct Window.
Using a std::unique_ptr would make sense.
Resorting to std::shared_ptr creates a lot of unnecessary complexity and overheads. You'd be better off just forgetting about the Viewport pointer cache and iterating the window hierarchy like before.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
It is true that neither are strictly necessary so long as the program is correct. It's aimed more as a safeguard for that one obscure case where some part of the program takes a (temporary) reference to a viewport and the window owning it gets deleted. Likewise, there should never be a case of a viewport pointer in the cache being invalid; so long as the program can never delete a viewport while another part of it is iterating through them.
Similar story for the viewport overlays: unless it can be proven that nothing can hold a reference to an overlay beyond the lifespan of its owning viewport, it needs to be a shared pointer for the program to remain correct.
I am happy to use unique_ptr
s if it makes sense to do so; I was acting upon @michicc's suggestion to move to automatic memory management.
…g window list. This is to speed up marking all viewports dirty, which is done very frequently.
…acked for later redrawing Track dirty viewport areas seperately form general screen redraws. Maintain a dirty block grid per viewport, with a smaller block size. Use even smaller block size in viewport map mode. Use a rectangle array for general screen redraws instead of a block grid. Add a dirty bit to windows and widgets, to simplify the common case of repainting a whole window or widget, without catching neighbouring windows or viewports.
Hash mark must go in first column, as per https://wiki.openttd.org/Coding_style#Other_important_rules
Partially re-applies 8652a4d, which was reverted to allow commits to be cherry-picked from JGRPP.
AddDirtyBlocks is an internal implementation detail of SetDirtyBlocks, and its name should reflect that.
The viewport cache is transparently managed by the ViewportData struct, and memory associated with the viewport and cache is automatically managed using smart pointers.
Some places in the codebase misspell 'Viewport' as 'ViewPort' or 'view_port'. This patch makes everything consistent.
Since they are only ever called with an int and a (int)uint; the templating seems completely unnecessary and redundant.
907116e
to
a85c053
Compare
This branch aims to take the improved dirty block tracking that @JGRennison developed for JGRPP earlier this year and patch it into
master
so that everyone can benefit from it.Although the code compiles and the game seems to work properly, please consider this a work in progess; as there were a lot of commits I had to find and cherry-pick, I cannot be sure that I got them all, and I had to revert my recent patch to
master
to get it to work. Extensive review, testing, and feedback is recommended.Once we are sure this is an accurate representation of JGR's changes, I can use it as a base for further work in my quest of decoupling the user interface from the simulation engine.