Skip to content

Commit

Permalink
Some minor modification to the code to make it a little more readable
Browse files Browse the repository at this point in the history
  • Loading branch information
rajarshi committed Mar 30, 2012
1 parent 1324985 commit a23d689
Showing 1 changed file with 5 additions and 4 deletions.
Expand Up @@ -841,10 +841,11 @@ private static void arcConstructor(RGraph gr, IAtomContainer ac1, IAtomContainer
for (int j = i + 1; j < gr.getGraph().size(); j++) {
RNode y = gr.getGraph().get(j);

a1 = ac1.getBond(gr.getGraph().get(i).getRMap().getId1());
a2 = ac2.getBond(gr.getGraph().get(i).getRMap().getId2());
b1 = ac1.getBond(gr.getGraph().get(j).getRMap().getId1());
b2 = ac2.getBond(gr.getGraph().get(j).getRMap().getId2());
a1 = ac1.getBond(x.getRMap().getId1());
a2 = ac2.getBond(x.getRMap().getId2());

This comment has been minimized.

Copy link
@egonw

egonw Mar 30, 2012

Member

Can you give x a more descriptive variable name?

b1 = ac1.getBond(y.getRMap().getId1());
b2 = ac2.getBond(y.getRMap().getId2());

if (a2 instanceof IQueryBond) {
if (a1.equals(b1) || a2.equals(b2) ||
Expand Down

2 comments on commit a23d689

@rajarshi
Copy link
Member Author

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

I chose not to so as to minimize the code changes. I'd rather keep the code as is (in this case, it's quite clear from the loop what x and y are)

@egonw
Copy link
Member

@egonw egonw commented on a23d689 Apr 1, 2012

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Understood.

Please sign in to comment.